RTL8366S Datasheet – 6-port Gigabit Ethernet Switch
SINGLE-CHIP 5+1-PORT 10/100/1000 MBPS SWITCH CONTROLLER
RTL8366S overview
The RTL8366S is an SINGLE-CHIP 5+1-PORT 10/100/1000 MBPS SWITCH CONTROLLER made by Realtek, supplied in these packages: 164, 216-pin Type. The absolute maximum ratings table on this page lists the 6 limits from the manufacturer's datasheet that must not be exceeded. This page brings together the RTL8366S pinout and maximum ratings, with the full datasheet PDF to preview below or download.
The RTL8366S/SR is a 164/216-pin, ultra low power; high-performance 6-port Gigabit Ethernet switch integrates 5-port Giga-PHY that support 1000Base-T, 100Base-T, and 10Base-T. RTL8366S (LQFP-164) uses the smaller package to minimize PCB size and RTL8366SR (LQFP-216) supports more MAC/PHY interfaces for Router and external CPU application. RTL8366S/SR integrates all the functions of a high- speed switch system—including SRAM for packet buffering, non-blocking switch fabric, and internal register management a single 0.13um CMOS device. Only a 25MHz crystal is required; the EEPROM is optional to configure internal registers.
The 5-th port MAC or PHY, and 6-th port MAC of the RTL8366SR implements dual MII/RGMII (or single GMII for 6-th port MAC) interface for connecting with an external PHY or MAC in specific applications. These interfaces could be connected to external CPU or RISC as 5port Gigabit Router application
The embedded packet storage SRAM in the RTL8366S/SR features superior memory management technology to efficiently utilize the memory space. The RTL8366S/SR also integrates a 1K entries address look-up table with a 10-bit 4-way XOR Hashing algorithm for address searching and learning. Auto aging of each entry is provided and the aging time is around 200-400 seconds. 8 Filtering Database are used to provide Independent VLAN Learning and Shared VLAN Learning (IVL/SVL) function.
The RTL8366S/SR supports standard 802.3x flow control frames for full duplex and optional backpressure for half duplex. It determines when to invoke the flow control mechanism by checking the availability of system resources, including the packet buffers and transmitting queues. The RTL8366S/SR supports broadcast/multicast output dropping method, which will forward broadcast/multicast packets to the non-blocked ports only. For the increasing IP multicast application, the RTL8366S/SR supports IPv4 IGMPv1/v2/v3 and IPv6 MLDv1/v2 snooping.
In order to support flexible traffic classification, RTL8366S/SR supports 32-entry ACL rule and multiple actions option. Each port can optional to enable or disable ACL rule check function. ACL rule key can base on packet ingress port, destination/source MAC address, 802.1q VID, 802.1q PRI, EtherType field, destination/source IP address, destination/source port number (TCP and UDP), ICMP, and IGMP. When ACL rule matches, action configuration can choose to Drop/Permit/Redirect/Mirror, change priority value in 802.1q/Q tag, and rate policing. The rate policing mechanism supports 64kbps step up to 1Gbps rate.
In Bridge operation, RTL8366S/SR supports 8 sets (based on Filtering Database) configurable port status: disable, block, learning, and forwarding for Spanning Tree Protocol and Multiple Spanning Tree Protocol. To meet the security and management application, RTL8366S/SR supports IEEE 802.1x Port- based/MAC-based Access Control. For those ports that do not pass the IEEE802.1x authentication, RTL8366S/SR also provides Port-based/MAC-based Guest VLAN function for them to access limited network resource. 1 set Port Mirroring function is configured to reflect the traffic appearing on another one of switch’s port RX, or TX, or both. It also supports many RFC MIBs Counters on each port for easy debug and diagnostic.
To improve real-time or multimedia networking applications, the RTL8366S/SR supports four priority- assignment for each received packet. These are based on (1) Port based priority; (2) 802.1p/Q VLAN tag priority; (3) DSCP field in IPv4/IPv6 header; and (4) ACL-assigned priority. Each output port supports a weighted ratio of four priority queues to fit bandwidth requirements in different applications. Input bandwidth control function helps user to limit per-port traffic utilization. There are 2 leaky buckets for each queue of all ports, one for Average packet rate and the other for Peak packet rate control. Queues scheduling algorithm can use Strict Priority (SP) or Weighted Fair Queue (WFQ) or mixed.
The RTL8366S/SR provides 4K entries VLAN table for 802.1Q Port-based, Tag-based, and Protocol- based VLAN operation to separate logical connectivity from physical connectivity. RTL8366S/SR supports 4 sets Protocol-based VLAN configuration, which can optional select EtherType, LLC, and RFC1042 as search key. Each port may be set to any topology via EEPROM upon reset or EEPROM SMI Slave interface after reset. The RTL8366S/SR also provides options to meet special VLAN application requirements. The first option is the ARP VLAN function, which is used to select to broadcast ARP frames to all VLANs or only forward ARP frames to the original VLAN. The second option is the Leaky VLAN function, which is used to select to send unicast frames to other VLANs or only forward unicast frames to the original VLAN. The VLAN tags can be inserted or removed on a per port basis.
In router applications, the router may want to know which input port of the incoming packet. The RTL8366S/SR supports an option to insert VLAN tag with VID = Port VID (PVID) on each egress port. The RTL8366S/SR also provides an option to admit VLAN tagged packet with a specific PVID only. If this function is enabled, RTL8366S/SR will drop all non-tagged packets and packets with an incorrect PVID.
Datasheet
RTL8366S features
- Single Chip 6 ports gigabit non-blocking switch architecture Embedded 5 ports 10/100/1000Base-T PHY
- Embedded 5 ports 10/100/1000Base-T PHY
- Each port supports full duplex 10/100/1000M
- connectivity (half duplex only supported in 10/100M mode)
- IEEE 802.3x flow control with asymmetric flow control ability
- 832Kbits SRAM for packet buffer
- Supports maximum packet length 16K bytes jumbo frame packet forwarding and 9216 bytes with wire speed
- Supports Real Tek Cable Testing (RTCT) Feature
- Media Independent Interface (MII)
- Gigabit Media Independent Interface (GMII)
- Reduced Gigabit Media Independent Interface (RGMII)
- Port 4 support 1000Base-X Serdes or UTP
- Support 32-entry ACL Rules
- Search keys support Source Port, MAC, TCP, UDP, IPv4, IPv6, ICMP, and IGMP format
- Actions support mirror, redirect, dropping, priority adjustment, and traffic rate policing
- Per-port can optional to enable/disable ACL function and set default action when ACL mismatch
- VLAN
- 802.1Q VLAN supports for 4096 entries
- Supports Port-based, Tag-based, and Protocol-based VLAN
- Up to 4 Protocol-based VLAN entries
- Supports per-port per-VLAN egress VLAN tagging and un-tagging
- Supports SVL and IVL/SVL
- Supports 1K MAC Address with 4-way hash algorithm
- Supports 8 entries CAM to avoid learning hash collision
- Up to 8 Filtering Database
- Supports Spanning Tree port status behavior configuration
- IEEE 802.1w Rapid Spanning Tree
- IEEE 802.1s Multiple Spanning Tree with up to 8 Spanning Tree Instances
- Supports IEEE 802.1x Access Control Protocol
- Port-Based Access Control
- MAC-Based Access Control
- Guest VLAN
- Supports Quality of Service (QoS)
- Input Bandwidth Control from 64Kbps to 1Gbps with 64Kbps step Four Priority Queues per port Per-port per-queue Average and Peak Packet Rate control Scheduling supports Strict Priority (SP) and Weighted Fair Queue (WFQ) IEEE 802.1p/Q and IPv4 DSCP Remarking
- Priority decision base on Port, 802.1Q VLAN tag PRI, IPv4/IPv6 DSCP, and ACL rule
- Support RFC MIB Counter
- MIB-II (RFC 1213)
- Ethernet-Like MIB (RFC 3635)
- Interface Group MIB (RFC 2863)
RTL8366S pinout
| Pin | Name |
|---|---|
| 1 | AVDDL |
| 2 | AVDDH |
| 3 | ATEST |
| 4 | AVDDH |
| 5 | AVDDH |
| 6 | LPFVOP |
| 7 | LPFVON |
| 8 | DVDDL |
| 9 | MDIREF |
| 10 | PLLGND1 |
| 11 | PLLVDDL1 |
| 12 | AVDDL |
| 13 | RTT1 |
| 14 | RTT2 |
| 15 | ATESTCK1 |
| 16 | AVDDH |
| 17 | AVDDL |
| 18 | P3MDIAP |
| 19 | P3MDIAN |
| 20 | P3MDIBP |
| 21 | P3MDIBN |
| 22 | AVDDL |
| 23 | AVDDH |
| 24 | P3MDICP |
Show all 59 pins
| Pin | Name |
|---|---|
| 25 | P3MDICN |
| 26 | P3MDIDP |
| 27 | P3MDIDN |
| 28 | AVDDL |
| 29 | AVDDH |
| 30 | P4MDIAP |
| 31 | P4MDIAN |
| 32 | P4MDIBP |
| 33 | P4MDIBN |
| 34 | AVDDL |
| 35 | AVDDH |
| 36 | P4MDICP |
| 37 | P4MDICN |
| 38 | P4MDIDP |
| 39 | P4MDIDN |
| 40 | AVDDL |
| 41 | XTALI |
| 42 | XTALO |
| 43 | AVDDH |
| 44 | SVDDH |
| 45 | SGND |
| 46 | SVDDT |
| 47 | SVDDL |
| 48 | SDCKN |
| 49 | SDCKP |
| 50 | SGND |
| 51 | SDTXN |
| 52 | SDTXP |
| 53 | SVDDL |
| 54 | SCKIN |
| 55 | SGND |
| 56 | SDRXN |
| 57 | SDRXP |
| 58 | SVDDL |
| 59 | DVDDL |
Absolute maximum ratings
| Parameter | Value | Unit |
|---|---|---|
| Maximum junction temperatures (Tj) | Max +125 | °C |
| Storage Temperature | Min -10 / Max +125 | °C |
| DVDDIO, AVDDH, and SVDDH Supply Referenced to DGND, AGND and SGND | Min GND-0.3 / Max +3.63 | V |
| DVDDL, AVDDL, SVDDL, and PLLVDDL Supply Referenced to DGND, AGND, SGND, and PLLGND | Min GND-0.3 / Max +1.32 | V |
| SVDDT Supply Reference to SGND | Min GND-0.3 / Max +1.65 | V |
| Digital Input Voltage | Min GND-0.3 / Max VDDIO+0.3 | V |
RTL8366S applications
- Ethernet Switching
- Network Infrastructure
- Data Communication
- LAN Switching
- Network Switches
Comments 0
Leave a comment